kernel-2.6.33で試してみる

ブートの不具合が果たして2.6.33で解決しているのかを確認すべく、2.6.33を導入してみました。

まず、Fedora13のα版がkernel-2.6.33を搭載していないかを確認。LiveCDをDVDに焼き込み、いざブート。

CDブートにもかかわらずやっぱり起動時フリーズ。現象は解決していません。
ついでに音が出るかを確認したかったのですが、残念ながらPhononに認識されていなかったので断念。alsaデバイスには存在していたのに。pulseaudioの標準デバイスがなぜかHDMIになってたんだよなぁ。まぁそこはgnome-control-centerがあればどうとでもなるんだけど、残念ながらKDEのLiveCDだったのでした。

気を取り直して、Fedora13用のリポジトリを覗いてみる。するとkernel-2.6.33のsrc.rpm発見。こいつをリビルドする事に。

ガリガリガリガリ、1時間ちょっと掛かったのかな? ようやくビルドを終え、インストールしようとしたら依存関係を訴えられた。悲しいかなFedora13向けのパッケージが必要なようで。

しゃーないのでkernel.orgからソースを取ってきてソースから試すことに。これまた1時間ちょっと掛けてカーネルビルド。

それをさくっとインストールしまして、いざ再起動!

・・・、結局何も変わらずOrz ただGRUBに入った瞬間がめっちゃ長くロードされてました。これについてはどうやらデバッグ情報を組み込んでカーネルを構築してしまったらしく、カーネルその物かinitramfsを作り直せば解決するとのこと。

手っ取り早いのはinitramfsを作り直すことだったんですが、気に入らなかったのでカーネルソースをリビルド。本日3度目のカーネルビルド。

そんでもって再起動。GRUBロード直後のデバッグ情報読み込みは無事回避されましたが、起動時のフリーズは解決せず。ほんとこれなんなんだろう・・・?

ただ、2.6.33で嬉しかった点はサウンドが正常に認識されるようになっていたことですね。tsched=0をつけていなくても音は正常に鳴ってますし、Webカメラのマイクも認識されてます。音周りはこれで一安心ですね。

しかし起動時のフリーズが全く解せない。しかも2.6.33系でも解決していないとなると非常に面倒よなぁ。せめて原因のきっかけでもつかめれば調べることもできるだろうし、あるいはバグ報告も出せるんだろうけれど皆目検討がつかず。

誰か似たような症状出てないのかなぁ?

広告

コメント / トラックバック2件

  1. 通りすがりのものです。
    その後、boot時の一時停止はいかがでしょうか?
    私も全く同じ現象で悩んでおりました。ハード構成もほぼ同じです。Gigabyteの785GとPhenom2です。
    bios設定を見直してみたのですが、結果、C1Eをdisableにすると一時停止せずにbootしました!
    boot時に省電力モードになってしまっていたのですかね。

    • 私のM/BにはC1Eの設定が見当たらなかったです><
      結局引っ掛かったままです。
      うーん、どこかにあるのを見落としてるのかな・・・?

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

%d人のブロガーが「いいね」をつけました。