• 管理者用

  • Twitter

    • @_ks マイクオンの方たちはむしろ、「うるせーこら切れよ!」っていわれたらええねん(過激派 やっぱり資料投影しますよねぇ? アイスブレイクのためとかかなー。 マイクオンもそうですが、たしかに相手のリアクションがわからなくて不安になる、ってことはありますね 1 hour ago
    • @2_5_dimension @_ks Teamsにはあったような… オンライン講義とかを想定した機能だったかなと 1 hour ago
    • @2_5_dimension @_ks そうそう、相手をミュートね(開催者権限 13 hours ago
    • @_ks 話してないときには環境ノイズ入れたくないから切りますねぇ テレワークだと窓開けてるんで、車とか飛行機の音が入っちゃうんですよねぇ。 カメラオン派が多いんですか!そうなんやなぁ…。 自分の周りではほぼないっすね! 13 hours ago
    • @_ks マイクのオンオフですか? どんなルールでしょう…? うちは帯域つらいからカメラは原則Off、くらいかなー マイクの方は話すとき以外オフが暗黙のルールですね 13 hours ago

kernel-2.6.33で試してみる

ブートの不具合が果たして2.6.33で解決しているのかを確認すべく、2.6.33を導入してみました。

まず、Fedora13のα版がkernel-2.6.33を搭載していないかを確認。LiveCDをDVDに焼き込み、いざブート。

CDブートにもかかわらずやっぱり起動時フリーズ。現象は解決していません。
ついでに音が出るかを確認したかったのですが、残念ながらPhononに認識されていなかったので断念。alsaデバイスには存在していたのに。pulseaudioの標準デバイスがなぜかHDMIになってたんだよなぁ。まぁそこはgnome-control-centerがあればどうとでもなるんだけど、残念ながらKDEのLiveCDだったのでした。

気を取り直して、Fedora13用のリポジトリを覗いてみる。するとkernel-2.6.33のsrc.rpm発見。こいつをリビルドする事に。

ガリガリガリガリ、1時間ちょっと掛かったのかな? ようやくビルドを終え、インストールしようとしたら依存関係を訴えられた。悲しいかなFedora13向けのパッケージが必要なようで。

しゃーないのでkernel.orgからソースを取ってきてソースから試すことに。これまた1時間ちょっと掛けてカーネルビルド。

それをさくっとインストールしまして、いざ再起動!

・・・、結局何も変わらずOrz ただGRUBに入った瞬間がめっちゃ長くロードされてました。これについてはどうやらデバッグ情報を組み込んでカーネルを構築してしまったらしく、カーネルその物かinitramfsを作り直せば解決するとのこと。

手っ取り早いのはinitramfsを作り直すことだったんですが、気に入らなかったのでカーネルソースをリビルド。本日3度目のカーネルビルド。

そんでもって再起動。GRUBロード直後のデバッグ情報読み込みは無事回避されましたが、起動時のフリーズは解決せず。ほんとこれなんなんだろう・・・?

ただ、2.6.33で嬉しかった点はサウンドが正常に認識されるようになっていたことですね。tsched=0をつけていなくても音は正常に鳴ってますし、Webカメラのマイクも認識されてます。音周りはこれで一安心ですね。

しかし起動時のフリーズが全く解せない。しかも2.6.33系でも解決していないとなると非常に面倒よなぁ。せめて原因のきっかけでもつかめれば調べることもできるだろうし、あるいはバグ報告も出せるんだろうけれど皆目検討がつかず。

誰か似たような症状出てないのかなぁ?

ブートの不具合?

kernel-2.6.32を熱望していた私なのですが、どうも実際に導入してみるとどえらいバグ?が。
ただ、私以外でそんな症状が発生しているのかはよく分からず。

どんな症状かと言うと、まぁフリーズなんですよ。しかもGRUBの起動シーケンス中に。不定期で。

ただ、完全に凍結というわけではなく、何かキーを押すとか、USBデバイスを抜き差ししてやるとか、システムに刺激を与えてやると動き出すみたいなんですね。それを与えないと時が止まったかのように沈黙すると言うこの不思議。

しかもその沈黙するタイミングと言うのもてんでバラバラ。場合によっては沈黙せずにKDMまで辿り着くこともあります。大概沈黙しますが。

しかもエラーらしきものはdmesgとか/var/log/messagesに表示されてないんですよね。なので原因を特定できずにいます。

唯一のヒントは2.6.31の頃には発生しなかったということ。あまりに小さなヒントではあるんですけれど。絞りきれません。

ちなみに、引っ掛からずに起動したら(Ctrlキーを押しっぱなしにした)、こんな感じで30秒ちょっとで起動できます。

で、引っ掛かったまま放置した場合こうなります。今朝の場合ですが、これはしょっぱなから引っ掛かりました。

はい、全く同じ構成にも関わらず5分も余計に掛かってます。不思議過ぎる・・・。

2.6.33でこの不具合が直っていることを期待しているのですが、そもそもなんでこんな不思議なことになっているのか分からないので手の打ちようもないんですよね。エラーも出てないし。
うーん、どうにかならんもんかしら???

radeonドライバでCompizを使う

先日の更新でradeonドライバでもCompizが使えるようになりました。
まだいくらか不安定ですが、Fedora12でATIのグラフィックチップを使っている場合、fglrxは使えないので、Compizを使いたかったらこれしか手はないんですよね・・・。

使えるとは言ってもかなり重いです。glxgearsのスコアは500程度・・・。これじゃそりゃ重いですわなぁ。
けどCompizのオプションをいろいろと設定し、軽いエフェクトばかりにしておけば実用上問題が出るほどパフォーマンスは落ちません。私に取って必要な「半透明」のオプションはほっとんど処理を食わないので非常に助かってます。

ちなみにCompizだけでなく、Gnome-ShellやKWinのCompositeも使えます。が、両方ともCompizに比べたらかなり重い印象・・・。今のradeonドライバではかなり厳しいんじゃないかと思います。

これは私だけの環境かもしれませんが、サブディスプレイの一部が微妙に描画されてません。ツールバーに相当する部分なんですが、デュアルディスプレイでの発生するんですかね? よく分かりませんが・・・。

KWinが描画領域として捉えられないだけ(?)で、そこにカーソルやウィンドウを持っていくことは可能です。Plasmoidは持っていけませんでした。これも今後改善されるかな・・・?

解決しました!

事の経緯はこちらをご参照ください。

i-nodeの不整合によって削除できなくなったファイルの削除方法

まさか画像ファイルが狂っていたとはなぁ。あと、debugfs最強。ただ扱うのはちょっとばかり勇気がいったけどw

これ以外にもこの土日は様々な不具合を解消できたり、今まで気になっていた事が見えたりしました。
このi-node不整合を筆頭に、

  • Amarokでプレイリストから消失していた楽曲が判明
  • ThunderbirdのLightningのエラーを解決
  • Choqokのゾンビプロセス大量発生の原因が判明
  • などなど。

    まずAmarokですが、これはたまたま判明。消え去っていたのはSoundHorizonのMoiraでした。なぜか16曲目の「神の光」だけは残ってて、こいつがいきなり再生されたので気付きました。アルバムシャッフルにしてたおかげだね! というかなんでこの1曲だけセーフで、残りの15曲がアウトなのかがさっぱり分かりません。どれが消え去っているかは分かったけどなぜ消え去るのかは一切不明なんだよなぁ・・・。ファイル名かはたまたタグか・・・。ただ、プレイリストに登録できないとかではなく、登録するとできるんだけど、一旦Amarokを終了して、次にAmarokを起動したらプレイリストから消え去っているという非常に説明しにくい現象です。致命的なバグではないけどどうにかならんかなぁ。

    続いて、Thunderbirdのバグ。というか、TB2系から3系へ移行した人くらいしか発生しないんじゃないかな? SQLiteのDBを再構築することで解決。割と面倒でしたね。

    最後のは予想外の現象に遭遇したところから端を発します。
    まず、昨日と今日、いきなりFirefoxがフリーズ。というかKDEのセッションを巻き込んで操作がものごっつ重くなりました。
    で、昨日は仕方なくログアウトして再ログインって形で解決したんですが、今日は何が原因かを突き止めるためにCtrl+Alt+F2でコンソールからログインした訳です。
    そしたらこんなのが出てきました。
    Twitpic – Share photos on Twitter
    何これ初めて見たんですけどw リソース食い尽くされるとかそんなこと有り得るのかね?

    で、リソースを食い尽くす可能性があるものとして真っ先に思い出したのがChoqok。Fedora11の頃から使ってますが、こいつなぜか異様にゾンビプロセスを発生するんですよね。小一時間放置でゾンビ130個みたいな。

    で、昨日今日は1日ず~っと起動してたので、おそらくゾンビプロセスがリソースを全部食い尽くしたのでしょう。そのタイミングでKDEがおかしくなったと考えるのが妥当です。

    となると、Choqokにそんな話題が出ているのかと思ったのですが特に出ていない。KDE-Apps.orgのChoqokスレで同様の症状に悩む方がコメントしてましたが、開発者に軽くスルーされてましたOrz

    で、どうなのよどうなのよとぶつぶつTwitterに呟いていたら、Manzyun氏から「私は発生していません」とのコメントが。

    つーことは私の設定に問題があるのだろうと怪しい設定を調べる。
    デフォルトから変更している点としてはNotificationをKNotifyからLibNotifyに変更したくらい・・・。ってこいつか!?

    はい、ビンゴ。KNotifyに戻すとゾンビプロセスは発生しなくなりましたとさ。
    悪かったな捻くれものでよ! だってタスクバーを上部に配置してるからKNotifyだと上部に通知ポップアップが出てうるさいんだよ! LibNotifyだと下部に出てくれて助かるんだよ!

    とはいってもゾンビプロセスは大変困るのでKNotifyに変更。というか通知その物が不要という話も。なんとなく通知させてるけど意味薄いのよなぁ。
    しかし、Choqokってまだ0.66だったのか。それで文句を垂れるというのは悪いね。機能といい見た目といい気に入っているので、今後もこれを使っていこう。もうちょっとで1.0のリリースらしいし。楽しみだ。

    ってな具合でこの土日はなかなかのラッキーデイになりました。HDDのfsckが発生しなくなった点が一番でかいね!
    ただAmarokの問題は未解決なんだよなぁ。消失している曲は分かったものの参った参った・・・。さてどうしようかね? 

    えーやっぱり回復しておりませんでしたOrz

    先日のポストで「回復したみたい」なんて書きましたが、やっぱり結果として同じでした・・・。

    どうも私が普段使っている何かが悪いらしい・・・。しかもKDE個人環境再構築したらradeonhdドライバでもコンポジット効かなくなっちゃった・・・。原因が分からん。

    とりあえず、怪しいのはAmarokかなぁと思ってはいますがこれなしではやってられないのでパーティションエラーを諦めます・・・? ほんとに原因はなんなんだろうなぁ。

    状態回復?

    ここしばらくずっと調子がおかしかったFedora12ですが、どうやら私のKDE環境が悪かった模様。
    意味不明なタイミングでクラッシュを繰り返すシステムに嫌気が差し、Twitterで_ks氏に「Gnomeでもおかしくなるのか試してみては?」とアドバイスも貰ったのでさっそく試してみることに。

    まず、KDEにログインしなければExt4のerrorが発生しないことを確認。次に、Gnomeでログインしようとしてログインに失敗することを確認(←
    どうやら個人設定が悪いらしい・・・。fedora11のときの設定をそのままコピーしてきたからなぁ。あのときはCompizも動いてたし、多分Compiz絡みだろう。けどどうしたもんだろうなぁ・・・。

    仕方ないので新しいアカウントを作って試してみることに。
    GnomeにログインしてもKDEにログインしてもExt4のerrorが発生しないことを確認。

    再起動してもfsckがかからないことを確認。しかしシャットダウン時のmballocは相変わらず0。これってどうなんよ^^;

    とりあえず、KDEの個人設定のどれかがまずいということは突き止めた。ただ、今更1個1個仕分けていくのも面倒な話なので、.kdeを吹っ飛ばして環境を再構築することに。

    環境再構築は小一時間で終了。副次効果として、異様に不安定だったスクロール時の画面ずれが少々、気持ち程度軽減されました。一回再起動しましたが、fsckは掛からなかった模様。Ext4のerrorも発生してません。

    と思ったら発生してますね・・・。これどういうタイミングで発生してるんだろ。つーことは同じように今回再起動したらfsck掛かるフラグ・・・?

    うーん、Amarokが怪しいかな・・・? けどAmarokのない生活は有り得ないしなぁ。もうちょっと様子を見ようか・・・。

    Fedora12が大変不調・・・?

    現在、起動する度にいつもいつもディスクチェックが掛かるようになってしまいました・・・。
    シャットダウン時、ext4の領域のアンマウント情報が出るんですが、そこで「mballoc」やらなんやらが常に0ってなってるんですよね。

    正常時にはそこに何らかの数値(多分書き込んだブロックサイズとかそんなんやと思う)が表示されます。0ってのがおかしいわけで。

    ただ、データが消失しているということはないみたい。とは言っても困るんだよなぁ。毎回毎回ディスクチェックなんかやってたら起動が遅くてかなわんし、そもそもディスクの寿命が早まってしまう・・・。

    そうでなくてもどこか不安定だしなぁ。今日もPDFをOkularで表示したらクラッシュしたし。OkularでPDFを見てクラッシュしたのは確か2回めじゃなかったっけ。両方ともATIのCatarystドライバに関するPDFを見ててクラッシュした気が。嫌がらせですか?w

    そんな派手なクラッシュのおかげでジャーナリングシステムに齟齬が発生。起動時に強制fsck。めっちゃ齟齬発生してて、それをfix fix。なんとかfixし終えて再起動したら、ひっさびさにディスクチェックが掛からない起動を楽しめたよ。あんまりうれしくないけどな!w

    うーん、kernelのバグなんだろうか・・? SMARTにはなんのエラーも記録されてないし。2.6.32に早く上がってほしいけど、なっかなか上がらないよね。もうそろそろ上がってもいいんじゃないの・・・?

    Fedora12でATIグラフィックドライバの導入に失敗

    まぁまだ対応してないってことは知ってたんですが、ちょっと出来心で入れて見たところ大惨事になりましたOrz

    とりあえず何も考えずにドライバをダウンロードしてインストール。xorg.confが書き換わっていることを確認して再起動。

    で、再起動したら見事にX立ち上がらず。というか、ログイン画面に差し掛かった段階で操作不能に。キーボードが利かなくなるのでリセットするしかない状態に。

    仕方ないのでgrubのブートメニューにて「init 3」を追加してテキストモードにて起動。
    この時点で起動できることは確認。ただ、ドライバをradeonに変更しても起動せず。radeonhdにしても起動せず。

    $ system-config –noui –set-driver=hoge –reconfig

    ってなコマンドでxorg.confが簡単に切り替えられることを学んだ。X起動しないんだから–nouiは必須。
    けどradeonにしてもradeonhdにしても起動しない。どうしてだと思ったらなんかfgrlxモジュールがロードされてる。
    そのくせXのログにはfglrxのモジュールがエラーとして出ているわけで…。
    つまるところ、ATIのドライバをアンインストールしたらいいのだろうと思い至る。

    けどインストーラに渡す引数に「uninstall」的なものが一切ない…。けど調べようにもGUIで立ち上がらない…。
    正直このあたりで手詰まり感が…。再インストールまで頭によぎった訳ですが、ギリギリになって
    「そういや最初はvesaドライバになってたな。これなら起動するんじゃね?」
    と思って急遽vesaドライバに差し替え。

    なんとか無事にXが起動。で、ググってみたら

    /usr/share/ati/fglrx-uninstall.sh

    で削除できることが判明。これで無事に削除でき、ドライバをradeonhdに戻すことができました。

    いやー、慣れないことはするもんじゃないなぁ…。というか削除の方法くらい調べてからやるべきだった。1時間は無駄にしたな…。

    うーん、そのうち対応はしてくれるんだろうけど相変わらず遅いなぁ。気長に待つかぁ。。。

    Fedora12 インストール記

    えー、Fedora12がリリースされたということでさっそくインストールしてみました。
    今回インストールしたマシンの構成は以下の通り。

  • CPU:PhenomII X4 905e
  • Mem:DDR3 4GB
  • M/B:GIGABYTE MA785GPMT-UD2H
  • で、まずLiveUSBで起動しようとしたら失敗。どうもログイン画面の直前でフリーズしてしまうらしい。
    LiveUSBがKDEだから悪いのだろうか、とか色々と考えて試してはみたもののにっちもさっちも。

    しゃーないのでNetinstCDでもってインストールを試みることに。
    こちらの起動メニューは通常のブートとベーシックなビデオドライバでのブートがあったのですが、ベーシックなビデオドライバでないと起動できませんでした。どうもビデオドライバの問題ということみたいですね。

    で、そこから先は何もトラブルなくインストール完了。Fedoraの割にノントラブルとかちょっと拍子抜けするなーなんて思わなくもない。

    で、起動後に適当にパッケージを追加して適当に設定。今回は初めてAMD系のビデオドライバとしたのですが、オープンソースのドライバだと3D機能が有効にできない。開発中というradeonhdを試してみるもダメ。まぁちゃんとradeonhdになっているかはよく分かってないのですが^^;

    ただ、radeonhdのドライバを使おうと使うまいと、サウンドはHDMI経由から出せるようです。デフォルトがそうなっててちょっとビックリ。サウンドは192kHzで出せるとかマニュアルに書いてあった気もしたんですが、PulseAudioで試したところ96kHzが限度でした。いやまぁ96kHzで十分だけどさ。

    旧PCからのデータも移行できましたし、radeonドライバでもデュアルディスプレイにはなっているので実用上問題はありません。Compizが使えないのが悲しいですが、それは今後のドライバの進化を楽しみにしておくとしましょう。

    プロプライエタリなドライバもあるようですが、そちらはまだ対応できてないようです。nVidiaの方はどうなっているか知りませんが、AMDが遅いのはいつものことらしいので気長に待ちますかね。

    旧PCから引き継げていないものとして、Postfixの設定があります。この設定をどうも間違っているらしく、プロセスが立ち上がらない…。
    エラーメッセージもでないので正直困ってます。後からじっくり調べてみよう。こいつがなくてもさして困りはしないけどさ…w

    ということで、クァッドコアを満喫しております。Firefox使っていても処理が重くならないのがいいですね。
    また、メモリはやっぱり4GB積んでいようとほぼフルで使いきろうとするんですね(笑) ディスクキャッシュが大半ですが、どんだけディスクキャッシュに喰うんだよと。面白いもんです。

    あとはCompizだけだなー。ドライバ開発ガンバレ!

    USBブートできた!

    えー、新しいPCを組んだはよかったのですが、事前にLiveUSB-Creatorで作っておいたFedora11のLiveUSBからブートできないという憂き目にあっておりまして。

    M/Bの販売代理店に質問投げてみると、Linuxは保証対象外だから自己責任でやってねっていうのと、USBブートはできるよ、WinVistaSP2のセットアップUSB作ってブートしてみたけどできたもんって回答でした。

    ということは私の環境が悪いと。ならばってことで、LiveUSB-Creatorではなく、LiveCD-Toolsの方で試してみることに。

    手順はオーソドックスに

  • USBメモリをFAT32でフォーマット
  • # livecd-iso-to-disk Fedora-11-Live-x86_64.iso /dev/sdc1
  • で、しばし待つと。私の持っているUSBメモリが書き込み速度遅いのか、結構時間が掛かりましたが無事完成。

    で、起動してみたら見事成功! という訳ですね。

    事前に作っておいたのはLiveUSB-Creatorで作ったのですが、こちらではダメだったということで、なんか仕様が違うんでしょうねぇ。そのときはFAT16だったんですが、それが原因とも考えにくいんだとか何とか。まぁ、動いたんだからよしとしよう。

    LiveUSB-Creatorとの違いといえば、書き込み可能領域を作れるかどうかってところくらいかな? けどそれはパーティションを分ければいいだけという気もする。USBメモリもパーティションを分けれたはずだし・・・。

    とりあえず、これでUSBメモリからブートができたので、OSのインストールができるようになったわけですが・・・、Fedor12のリリースが11/17予定なので、ここまで待つつもり。Fedora10から11に比べて、結構変更が大きそうだし。GRUBがExt4対応してるので、今作ると/bootをExt3で作ることになるしねぇ。

    ま、現在のPCが壊れている訳でもないので気長に待ちましょう。移行用データの準備だけしておきますかね。